PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Fehler IBX 4.41 und IBX 4.52 bzw. 4.6



Andreas Brueck
08.07.2001, 12:40
Hallo Herr Kosch,<p>
in Ihrem Beitrag im Entwickler-Magazin Ausgabe 2.2001 beschreiben Sie die Fehler die die IBX Version 4.41 enthält. In Ihrer Anwendung RedSys2 verwenden Sie IBX 4.52. Desweiteren habe ich festgestellt das es jetzt eine Version 4.6 von IBX gibt. Welche Fehler aus 4.41 sind dort noch gültig? Kann man IBX 4.6 bedenkenlos installieren? Was hat sich verbessert?<p>Gruss Andreas Brück

Andreas Kosch
09.07.2001, 09:02
Hallo,

der Autor von IBX (Jeff Overcash) empfiehlt, IBX 4.6 in ein deutsches Delphi 5 nur dann zu installieren, wenn die <i>German resource dll</i> in CodeCentral vorgefunden wird. Dies war bis heute morgen noch nicht der Fall - ich würde an Ihrer Stelle also warten.

Mit Delphi 6 gibt es eine Abspaltung von IBX: <br>
a) IBX 4.6 enthält ca. 90% der Sachen von IBX 6 <br>
b) IBX 6 arbeitet nur ab Delphi 6 aufwärts<br>
Auf der letzten Entwicklerkonferenz hatte ich in meiner IBX-Session mehrere IBX-Fehler (ca. 10) am praktischen Beispiel demonstriert. Für Delphi 6 (IBX 6) kann ich davon bis auf einen Bug alle anderen Beispiele wiederverwenden, es sind jedoch auch neue Probleme hinzugekommen :-)<br>
Bis auf den zweiten logischen Transaktions-Bug sind alle in der o.g. Ausgabe aufgelisteten Problem noch aktuell.

Da zur Zeit auch IBX 4.6 neue Probleme mit sich bringt, würde ich an Ihrer Stelle noch bei 4.52 bleiben (bis 4.6x + German resource dll in CodeCentral zur Verfügung steht)

Andreas Brueck
09.07.2001, 10:21
Hallo Herr Kosch!<p>Vielen Dank fü die schnelle Antwort. Es bleibt also abzuwarten was die Zukunft bringt. Noch was anderes: Nach der Installation von 4.52 bekomme ich, wenn ich mit derrechte Maustaste z.B. auf einer TIBDataset-Komponente klicke die Version 4.4 angezeigt. Ich habe mich extra nochmal versichert, daß ich das Setup der Version 4.52 installiert habe. Ist da was schiefgelaufen?<p>Gruss Andreas Brüc